28 Sep

Midnight system screwup (and fix!)

I was just working (and playing music!) and realized that “Movie player” package given on default Ubuntu installation isn’t of much use. 

Decided to uninstall it, next needed arping for some test and installed it (via default debian repository). Something crazy happened here. I opened something on personal server and it gave DNS error. I shot couple of digs from terminal and all timed it. I was scared to hell thinking of DNS failure on personal domain which is very very unlikely since I am using multiple DNS providers and close to a dozen of servers serving DNS zone. 

I ran ping to and that also failed. I realized it was simply internet issues. Nothing unusual on BSNL but when I tried to telnet BSNL router to see WAN link status, telnet also failed. I couldn’t even connect to LAN IP. Was my system out of internal network broadcast? Yes!

I gave ifconfig and saw only lo interface and realized the blunder!

As per history of software center, I uninstalled network-manager along with network-manager-gnone along with totem player. Strange!

Anyways, since I figured out it was simply missing network-manager package, I gave apt-get install network-manager in terminal and it failed since network was already disconnected!

OK – what can one possibly do in such situation? Can’t even Google on system. 🙂

Anyways, realized in a min that I don’t have network-manager on servers, do I? Nopes!

Thus, simply went to /etc/network/interfaces and added following lines

iface eth0 inet static
address MY-IP
gateway BSNL-router-gateway-IP


Incase you don’t run crazy filtering & NATing rules, you can simply use DHCP. You can add following line to get DHCP working:
iface eth0 inet dhcp

Next, restarting networking via usual /etc/init.d/networking restart and I was back online to install network-manager and write this blog post! 🙂


Have a happy package breaking ahead!